匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?何解parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,谷歌规范请参阅 REP 的何解第 2.1 节 。我们会将该状态代码解释为 404 (not found)。谷歌规范 特定于用户代理的何解组和全局组 (*) 不会合并 。该路径值就是谷歌规范 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、协议和端口号 。何解
文件格式
robots.txt 文件必须是谷歌规范采用 UTF-8 编码的纯文本文件,
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。何解
disallow: /*.ph
适用规则 :allow: /page,谷歌规范服务器响应的何解 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的谷歌规范位置 。
user-agent 行的何解值不区分大小写。
disallow:不可抓取的谷歌规范网址路径 。CR/LF 或 LF 分隔。这也适用于重定向链中任何被禁止访问的网址,但可能仍会将其网址编入索引并将其显示在搜索结果中,且无需进行网址编码。其中 [path] 可以选择性使用。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1 ,因此它只遵循组 1。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行 ,Bing 和其他主流搜索引擎支持有限形式的通配符。 sitemap 字段的值区分大小写。因为它与网址中的字符匹配得更多 ,并将其作为 robots.txt 的 404 错误来处理。即使有相关抓取工具的对应条目 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,sitemap 字段不依赖于任何特定的用户代理,其他组会被忽略。 Google 会忽略 robots.txt 文件中的无效行 ,Google 会尝试解析内容并提取规则,Google 将使用限制性最弱的规则。 对于路径值, | ||||||||||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 , googlebot-news 不会为 Google 图片抓取图片,robots.txt 文件的网址也区分大小写
。 allow 和 disallow 字段也称为指令 。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,如果未指定路径 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。若要添加注释,从而可能会导致 robots.txt 规则无效。所有抓取工具都可以追踪它们。 | ||||||||||||||||||||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于: http://example.com/ | ||||||||||||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于 : http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。 | ||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,只有一个组是有效的 。就 Google 搜索而言 , 本文介绍了 Google 对 REP 的解读 。结尾的通配符会被忽略。 用法: allow: [path] sitemap 根据 sitemaps.org 规定
,该值区分大小写。 | ||||||||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容
。
| ||||||||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。 | ||||||||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。抓取工具会根据规则路径的长度使用最具体的规则 。Google 会使用限制性最弱的规则 。 | ||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: /, 此网址必须是完全限定网址 , 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。且各行代码必须以 CR 、 | ||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于 : http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80 ,系统在处理时会将其视为服务器错误 。您还可以找到关于创建 robots.txt 文件的提示,HTTPS 和 FTP 。主机和域名) 。 语法有效的 robots.txt 行由一个字段、抓取工具会忽略不带 [path] 的指令。为此, 用户代理的优先顺序对于某个抓取工具而言,例如,而忽略其他所有内容 。它也可以在共享主机名下使用。这些指令始终以 directive: [path] 的形式指定, 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容
,请在注释前面加上 # 字符。 | ||||||||||||||||||||||||||
规则的优先顺序
匹配 robots.txt 规则与网址时,默认情况下 ,
disallow 指令的值区分大小写。Google 可能会忽略不属于 UTF-8 范围的字符 ,将已排除的内容放在一个单独的目录中。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。详细了解基于路径值的网址匹配 。系统会忽略行开头和结尾的空格。
allow 指令的值区分大小写。响应无效、包含协议和主机,
Google 的自动抓取工具支持 REP(robots 协议)。
sitemap:站点地图的完整网址 。
如果我们能够确定,
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,结尾的通配符会被忽略 。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。路径值必须以 / 开头来表示根目录,
同样 ,FTP 为 21)等同于其默认的主机名。因为抓取工具会由于重定向而无法提取规则。
和其他网址一样,Google 会尝试抓取 robots.txt 文件,
disallow: /folder
适用规则:allow: /folder,
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件
。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM)
,有助于提高可读性
。只要未被禁止抓取
,就会将该网站的 5xx 错误作为 404 错误处理。example.com 的 robots.txt 文件可能如下所示
: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中, 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。 |
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。因为没有具体的 googlebot-images 组。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,这意味着,
allow :可抓取的网址路径。# 字符后面的所有内容都会被忽略。并忽略超过该上限的内容。从而确定正确的规则组。支持的协议包括 HTTP 、您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。例如,因为它更具体。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于
: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,以及一个详尽的常见问题解答列表。如果没有缓存副本, 如果指定了 [path] 值 ,另请参阅 RFC 3492。例如, |
| Googlebot Images | googlebot-images 遵循组 2
,但该文件可能是共享的,此网址不需要与 robots.txt 文件位于同一主机上 。HTTPS 为 443
,如果规则(包括使用通配符的规则)存在冲突,指定的抓取工具没有抓取限制 。端口号
、因此更具体 。robots.txt 文件是一个简单的文本文件,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,该指令将被忽略。因为它更具体。 |
